Fórum Como Fazer Um Site
https://www.comofazerumsite.com/forum/

PROBLEMA COM LOAD AJAX
https://www.comofazerumsite.com/forum/viewtopic.php?f=8&t=194
Página 1 de 1

Autor:  tiago [ quarta mar 25, 2015 5:01 pm ]
Assunto da Mensagem:  PROBLEMA COM LOAD AJAX

Quando clico no botão "Adicionar", é adicionado um novo procedimento, então é criada um linha para eu escrever o procedimento e "Cadastrar". Quando eu clico em Adicionar, eu não consigo cadastrar, ou seja, depois que é feito o "load", não funciona mais meu botão "Cadastrar", então tenho que dar um F5, alguém sabe o porque?
----------------PARTE DO HTML/PHP-------------------------------

Código:
<div class="tab-pane" id="tab3">
                            <div class="span12 well" style="padding: 1%; margin-left: 0">                           
                                <form id="formAndamentos" action="<?php echo base_url() ?>os/adicionarAndamento" method="post">
                                        <input type="hidden" name="idOs" id="idOs" value="<?php echo $result->idOs?>" />
                                        <label for="">Adicionar Procedimento</label>
                                        <button class="btn btn-success"><i class="icon-white icon-plus"></i> Adicionar</button>
                               
                            </div>
                            <div class="span12" id="divAndamentos" style="margin-left: 0">
                                <table class="table table-bordered">
                                    <thead>
                                        <tr>
                                            <th>Data Inicial</th>
                                            <th>Procedimento</th>
                                            <th>Data Final</th>     
                                            <th>Usuário</th> 
                                            <th>Editar</th>                                     
                                        </tr>
                                    </thead> 
                                    <tbody>
                                     <?php foreach ($andamentos as $andamento) { ?> 
                                       <tr>
                                        <form action="<?php echo base_url() ?>os/adicionarProcedimento" method="post">
                                           <td><?php echo $andamento->data_inicio ?></td>
                                            <td><textarea class="span12" name="procedimentos" id="procedimentos" cols="30" rows="3"><?php echo $andamento->procedimento ?></textarea></td>
                                            <td><?php if ($andamento->data_fim == "0000-00-00 00:00:00") echo ""; else echo $andamento->data_fim ?></td>
                                            <td>                                 
                                 <?php echo $andamento->nome ?></td>
                                            <td>
                                           <input type="hidden" name="idAndamentos" id="idAndamentos" value="<?php echo $andamento->idAndamentos?>" />
                                            <button <?php if ($andamento->procedimento!="" || $andamento->usuarios_id!=$this->session->userdata('id')) echo "disabled"; ?> class="btn btn-success span6"> Cadastrar</button>
                                    </td>
                                            </form>
                                        </tr>
                                       
                                     <?php } ?>
                                     
                                    </tbody>                                 
                                </table>
                            </div>
                        </div>




---------------------AJAX-------------------------------------------
Código:
$("#formAndamentos").validate({
          submitHandler: function( form ){
                 var dados = $( form ).serialize();
                $("#divAndamentos").html("<div class='progress progress-info progress-striped active'><div class='bar' style='width: 100%'></div></div>");
                $.ajax({
                  type: "POST",
                  url: "<?php echo base_url();?>os/adicionarAndamento",
                  data: dados,
                  dataType: 'json',
                  success: function(data)
                  {
                    if(data.result == true){
                        $( "#divAndamentos" ).load("<?php echo current_url();?> #divAndamentos" );                     
                    }
                    else{
                        $( "#divAndamentos" ).load("<?php echo current_url();?> #divAndamentos" );
                  alert('Aguarde mais de 5 minutos para colocar novo procedimento.');
                    }
                  }
                  });
                  return false;
                }
       });

Autor:  tiago [ quarta mar 25, 2015 10:53 pm ]
Assunto da Mensagem:  Re: PROBLEMA COM LOAD AJAX

alguém?

Página 1 de 1 Os Horários são TMG [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/